Downloads

Pcounter 3.01 for Windows - July 26, 2017
Pcounter 3.x requires a database server such as MS SQL Server or MySQL.  If you do not have a database, then you can download SQL Express.  Pcounter 2.x users can upgrade and migrate the data using the dbupdate3.exe utility.  Earlier versions of PPopup will not work with 3.01 and additional products such as Pcounter Embedded and Pcounter Station will need to be updated to the latest versions to work with 3.01.
New customers
60 day trial included
Registered customers
Please do not install if your registration number has a maintenance date earlier than 7/2017.
Download: North America
  How to check the maintenance date?
  Revision history
  How to upgrade from previous versions?
  Request a trial period extension

Pcounter 2.90 for Windows - July 26, 2017
This is a direct upgrade from earlier Pcounter versions.  Earlier versions of PPopup will not work with 2.90 and additional products such as Pcounter Embedded and Pcounter Station will need to be updated to the latest versions to work with 2.90.
New customers
60 day trial included
Registered customers
Please do not install if your registration number has a maintenance date earlier than 7/2017.
Download: North America
  How to check the maintenance date?
  Revision history
  How to upgrade from previous versions?
  Request a trial period extension